How to install Glibc-2.15 on CentOS6

From wiki.mikejung.biz
Jump to: navigation, search

Installing glibc-2.15 on CentOS 6

DO NOT ATTEMPT TO REPLACE THE DEFAULT VERSION OF GLIBC. This will result in a bad time. However, you can install additional versions of glibc along side the OS's version. You can use these newer versions to compile / install software that requires newer versions of glibc, such as GeekBench4.

To install glibc-2.15 run the following commands.

mkdir ~/glibc_install; cd ~/glibc_install 
wget https://ftp.gnu.org/gnu/glibc/glibc-2.15.tar.gz
tar zxvf glibc-2.15.tar.gz
cd glibc-2.15
mkdir build
cd build
../configure --prefix=/opt/glibc-2.15
make -j4
sudo make install

To use the new version of glib for your current session, run the command below. PLEASE NOTE that this may break things such as "yum", but only for your session. To revert back to the original version simply replace 2.15 with the original glibc version

export LD_LIBRARY_PATH=/opt/glibc-2.15/lib

If you need a different version of glibc, simply wget the proper version and replace "-2.15" with the version you need. For example:


mkdir ~/glibc_install; cd ~/glibc_install 
wget https://ftp.gnu.org/gnu/glibc/glibc-2.17.tar.gz
tar zxvf glibc-2.17.tar.gz
cd glibc-2.15
mkdir build
cd build
../configure --prefix=/opt/glibc-2.17
make -j4
sudo make install
export LD_LIBRARY_PATH=/opt/glibc-2.17/lib